Just starting out? Need help? Post your questions and find answers here.
User avatar
Paul
 
Posts: 87
Joined: Wed Feb 26, 2014 6:46 pm
Location: Canada

Re: 2.31 final: 404 error on compile run

by Paul Mon May 18, 2020 7:53 pm

SinisterSoft wrote:It looks like port 9080 is being used by Logitech for their gaming software.
Maybe SpiderBasic should have a way of specifying the port range used for testing?


Image

OR

Image
Last edited by Paul on Mon May 18, 2020 7:59 pm, edited 1 time in total.
User avatar
SinisterSoft
 
Posts: 77
Joined: Sun Apr 06, 2014 11:41 pm
Location: Preston, UK

Re: 2.31 final: 404 error on compile run

by SinisterSoft Mon May 18, 2020 7:56 pm

Ahh, thanks.

Not a bug, but maybe as it's Logitech that are using the port too, it may be a good idea to use a different one as it may be quite common.
User avatar
Paul
 
Posts: 87
Joined: Wed Feb 26, 2014 6:46 pm
Location: Canada

Re: 2.31 final: 404 error on compile run

by Paul Mon May 18, 2020 8:04 pm

Always a challenge to find a vacant port that someone else might also decide to use...
https://en.wikipedia.org/wiki/List_of_TCP_and_UDP_port_numbers

Very nice that Fred included the option to adjust the ports when needed :)
User avatar
SinisterSoft
 
Posts: 77
Joined: Sun Apr 06, 2014 11:41 pm
Location: Preston, UK

Re: 2.31 final: 404 error on compile run

by SinisterSoft Mon May 18, 2020 8:15 pm

Yes. :)

I wonder why 9081 was also used - that port wasn't the one set.
Fred
Site Admin
 
Posts: 1298
Joined: Mon Feb 24, 2014 10:51 am

Re: 2.31 final: 404 error on compile run

by Fred Tue May 19, 2020 6:20 am

Interesting, did you just install this software ? I will try to find a default range less crowed..
Fred
Site Admin
 
Posts: 1298
Joined: Mon Feb 24, 2014 10:51 am

Re: 404 error on compile run

by Fred Tue May 19, 2020 6:21 am

Moved to coding question for future refence if someone has the same issue
User avatar
Peter
 
Posts: 727
Joined: Mon Feb 24, 2014 10:17 pm
Location: 127.0.0.1:9080

Re: 404 error on compile run

by Peter Tue May 19, 2020 6:30 am

This is admittedly a rare problem, but wouldn't it be a good idea for SpiderBasic to report when the corresponding port is blocked?

Greetings ... Peter
User avatar
SinisterSoft
 
Posts: 77
Joined: Sun Apr 06, 2014 11:41 pm
Location: Preston, UK

Re: 404 error on compile run

by SinisterSoft Tue May 19, 2020 7:39 am

@fred Logitech 'recommended' the software in an update for both my mouse and my webcam, I think it also recommends it for their gaming keyboards. Their hardware/software is pretty common so I expect this will happen now quite often. I updated the software after the last beta, before that they didn't use the port I think.

@peter yes, a check beforehand then a warning would be good.
Fred
Site Admin
 
Posts: 1298
Joined: Mon Feb 24, 2014 10:51 am

Re: 404 error on compile run

by Fred Tue May 19, 2020 8:02 am

Testing the port at every laucnh could long, sometimes it takes several seconds. I don't know if there is a solid solution for this. Or may be moongose output an error and the IDE ignores it, I will look closer.
Return to Coding Questions

Who is online

Users browsing this forum: No registered users and 2 guests