Just starting out? Need help? Post your questions and find answers here.
kpeters58
 
Posts: 10
Joined: Fri Dec 07, 2018 7:27 pm

Newbie Port/Webserver issue

by kpeters58 Tue Jan 29, 2019 6:40 am

I have an existing project that has been running reliably when started from the IDE. I have port 9080 (I believe the default?) specified in Preferences.
My first program runs fine @ this URL:

http://127.0.0.1:9080/SpiderBasic_Compilation1.html


Today I created a new project (with Beta 3) and apparently it wants to run on a strange port?
The URL I see has 9081 as port, even though I haven't set that anywhere. Consequently my app won't run.

http://127.0.0.1:9081/SpiderBasic_Compilation1.html

I have shut down all browser windows, restarted SB, rebooted...
What might I be missing?

Thanks for any help!
Fred
Site Admin
 
Posts: 1134
Joined: Mon Feb 24, 2014 10:51 am

Re: Newbie Port/Webserver issue

by Fred Tue Jan 29, 2019 8:20 am

Did you check in the "compiler option", you also have a field to setup the port
kpeters58
 
Posts: 10
Joined: Fri Dec 07, 2018 7:27 pm

Re: Newbie Port/Webserver issue

by kpeters58 Tue Jan 29, 2019 5:23 pm

Hmm - I can't see any port field in Compiler Options; I see only the one in Preferences -> Compiler and that one is set to 9080.

But since you wrote 'also' you are implying that there are at least two port fields. Could you be more specific as to where the 2nd one is?

I checked all three tabs of Compiler Options multiple times....

Thanks1
kpeters58
 
Posts: 10
Joined: Fri Dec 07, 2018 7:27 pm

Re: Newbie Port/Webserver issue

by kpeters58 Tue Jan 29, 2019 7:21 pm

I just installed SB beta 3 on a brand new machine and here I see almost the same results:

I did not modify the default port in Preferences, so it is set to 9080.

Project A has a port of 9080 in its URL

Project B has a port of 9081 in its URL

On the new machine, both run fine (on the old machine, only project A runs, project B gets 'Connection to 127.0.0.1:9081 refused')

Where does the 9081 port come from? I checked and it's not in the SBP file.
User avatar
Paul
 
Posts: 50
Joined: Wed Feb 26, 2014 6:46 pm
Location: Canada

Re: Newbie Port/Webserver issue

by Paul Tue Jan 29, 2019 8:25 pm

kpeters58 wrote:Hmm - I can't see any port field in Compiler Options; I see only the one in Preferences -> Compiler and that one is set to 9080.


I think he means here...

Image

You could load your SB file into Notepad and view the hidden data to see if it references a different port.
Return to Coding Questions

Who is online

Users browsing this forum: No registered users and 6 guests