Found an issue in SpiderBasic ? Please report it here !
Dirk Geppert
 
Posts: 114
Joined: Fri Sep 22, 2017 7:02 am

[Done] ListIconGadget and SetGadgetItemImage not work?

by Dirk Geppert Mon Dec 17, 2018 11:29 am

Hi guys,

what I'm doing wrong here:

Code: Select all
CreateImage(0, 16, 16, 32, #Red)
CreateImage(1, 16, 16, 32, #Blue)

OpenWindow(0, 0, 0, 600, 400, "ListIcontest", #PB_Window_SystemMenu)
ListIconGadget(0, 0, 0, 600, 400, "", 600,  #PB_ListIcon_GridLines | #PB_ListIcon_FullRowSelect  | #PB_ListIcon_AlwaysShowSelection )

AddGadgetItem(0, -1, "Test with red image", ImageID(0))
AddGadgetItem(0, -1, "Test with red image changed to blue..", ImageID(0))

SetGadgetItemImage(0, 1, ImageID(1))


I thought I could change the picture that way..
poshu
 
Posts: 89
Joined: Mon Feb 24, 2014 11:46 pm

Re: ListIconGadget and SetGadgetItemImage not work?

by poshu Tue Dec 18, 2018 5:19 pm

Confirmed, it doesn't work here either, this topic should be moved to bug reports.
User avatar
Peter
 
Posts: 589
Joined: Mon Feb 24, 2014 10:17 pm
Location: 127.0.0.1

Re: ListIconGadget and SetGadgetItemImage not work?

by Peter Tue Dec 18, 2018 7:07 pm

it seems, that SetItemImage() is not present:

Image

Image
Fred
Site Admin
 
Posts: 1134
Joined: Mon Feb 24, 2014 10:51 am

Re: ListIconGadget and SetGadgetItemImage not work?

by Fred Tue Jan 15, 2019 9:44 am

Moved to bug report
Fred
Site Admin
 
Posts: 1134
Joined: Mon Feb 24, 2014 10:51 am

Re: ListIconGadget and SetGadgetItemImage not work?

by Fred Sun Jan 27, 2019 1:36 pm

Fixed.
User avatar
Peter
 
Posts: 589
Joined: Mon Feb 24, 2014 10:17 pm
Location: 127.0.0.1

Re: ListIconGadget and SetGadgetItemImage not work?

by Peter Sun Jan 27, 2019 2:36 pm

Fred wrote:Fixed.

Confirmed! Works now (with SB 2.21 Beta 3).

Thanks & Greetings ... Peter
Return to Bugs Reports

Who is online

Users browsing this forum: No registered users and 1 guest