Just starting out? Need help? Post your questions and find answers here.
Posts: 2
Joined: Tue Jan 02, 2018 8:29 pm

Noob Android Question

by tangent685 Tue Jan 02, 2018 8:39 pm

Hi, I have just purchased SpiderBasic and tried out the example programs with no problem. I then installed JDK in C:\Program Files (x86)\Java\jdk1.8.0_151\ and pointed to that directory in the compiler preferences to try out an example program on my Android phone. I have filled out the information under "create app" with name, com.program.test, enabled debugging, and checked the box to auto upload to my phone via usb cable (connected). I when the program is compiling I get the following message:

Error: Invalid Version: Broken

I reinstalled cordova after getting this message. Any help would be greatly appreciated.

Edit to add: I am using 32 bit SpiderBasic on Windows 10. I have given a file name and location for the apk, but none is created. The compiler usually stops at around 40%
Posts: 12
Joined: Tue Jan 02, 2018 6:59 pm

Re: Noob Android Question

by firace Wed Jan 03, 2018 7:02 am

I think I had that issue when disabling my Internet connection. The apk build process requires Internet connectivity.
Posts: 2
Joined: Tue Jan 02, 2018 8:29 pm

Re: Noob Android Question

by tangent685 Wed Jan 03, 2018 10:41 pm

My internet was turned on (wifi). I am kind of curious about what "Invalid Verision" of something I may have. I installed the latest JDK and Cordova through the latest node.js using the npm command. I also made sure my computer could see my phone (showing up in My Computer). I have tried to build an app from several of the example files with the same result each time. My JRE is also the latest version.

I also tried to just build to an apk without having the phone connected with the same results. I also have AGK which runs programs with no problem through bluetooth to my phone on the AGK app runner.

The debug window basically states that it compilation has started and has stopped. I think if fails when trying to build the app. Do I have to run as administrator? Or should I try to install the 64 bit version of SB? Is there a way I can debug the process in the jdk somehow? Could something be blocking the jdk? If I try to build the app again after the first fail I get a window as follows:

https://www.dropbox.com/s/1ykfl4q32s8d4 ... r.jpg?dl=0
Return to Coding Questions

Who is online

Users browsing this forum: No registered users and 2 guests