Everything else that doesn't fall into one of the other categories.
DanLJr
 
Posts: 45
Joined: Wed Jul 04, 2018 4:24 am

Re: Problems with StringsGadgets with iOS Browser

by DanLJr Wed Dec 12, 2018 8:39 pm

DanLJr wrote:Is this constantly failing with all StringGadgets under iOS? Or just when there is screen resizing happening? - which is pretty much always in my case.


It seems to be breaking across the board. I removed my resizing from my stuff, tried using a #PB_Window_BorderLess window instead of a #PB_Window_Background, as suggested in another thread:

viewtopic.php?f=6&t=1339#p4777

...but still no luck. This seems to be a core problem, and I'm guessing requires a fix - or provided work-around - from Fred.

At Peter's recommendation, I have PM'd Fred directly, so hopefully we will hear something on this pretty soon.

This is a HUGE deal for me, as it has already held-up release on my current project for my customer a couple of weeks, and everyone on this end is getting scared, as we are concerned that the end-customer will start looking for another solution soon, if we can't make this work!

Please help, Fred!
DanLJr
 
Posts: 45
Joined: Wed Jul 04, 2018 4:24 am

Re: Problems with StringsGadgets with iOS Browser

by DanLJr Thu Jan 17, 2019 7:57 pm

Peter wrote:
DanLJr wrote:Please, Fred. Help us. You're our only hope.

I don't know the last time Fred looked in here. I think it would be best if you wrote him a PM. Then he gets a notification by mail (I think).

Greetings ... Peter


Since Fred just moved a bunch of these threads to the Bug Reports area on this site, I'm assuming/hoping he's taking a look at some of these issues awhile.

I wanted to add that while this thread has been discussing iOS, my issues occur on Android devices as well. (It feels a little worse in iOS, but it is indeed a general problem. I recently had the opportunity to try in Chrome on an Android phone and on the native browser on another Android tablet.

I would also add that it isn't just focus on the string gadgets that was the problem, but most??? controls as a whole. (I tested with string gadgets as well as a set of radio buttons, and while I could get the radio buttons to click, it would take more than one attempt and act weirdly while doing so.

Bottom line: Input gadgets just don't seem to be working smoothly/properly in mobile browsers, and that is sort of essential for web apps/dev these days. (FYI: All of my gadgets are within a scroll area within window that was opened as the background window. I also tried NOT using background, just no borders - same result.)

A solution would be wonderful. I have a couple of applications just sitting on hold, awaiting a fix so we can release. (My sad customers have been sitting on their hands for a couple of months while we try to figure this out.)

Any help would be appreciated.

-Dan
Return to General Discussion

Who is online

Users browsing this forum: No registered users and 2 guests