Page 1 of 1

[Done] OS X: Font issue at system level

Posted: Thu Jan 28, 2016 9:07 am
by SparrowhawkMMU
Hi fred,

I have hundreds of instances of the following line in my OS X system Console log:

27/01/2016 17:00:35.325 SpiderBasic[3890]: CoreText performance note: Client called CTFontCreateWithName() using name "Courier New" and got font with PostScript name "CourierNewPSMT". For best performance, only use PostScript names when calling this API.


They don't appear to be causing any issues that I can tell, but it might be worth renaming the font to the suggested value - it might speed up IDE load times perhaps?

SB 1.20b2 OS X 10.9.5

Re: OS X: Font issue at system level

Posted: Thu Jan 28, 2016 9:08 am
by SparrowhawkMMU
FYI - I just checked and it also affects PureBasic (5.41 LTS):

28/01/2016 09:08:01.515 PureBasic[1811]: CoreText performance note: Client called CTFontCreateWithName() using name "Courier New" and got font with PostScript name "CourierNewPSMT". For best performance, only use PostScript names when calling this API.

Re: OS X: Font issue at system level

Posted: Tue Feb 23, 2016 3:29 pm
by SparrowhawkMMU
FYI: Still in SB 1.20, still "spamming" my console logs :(

I also spotted these two which you probably want to fix as otherwise a future OS X update may break SB:

23/02/2016 09:30:55.674 SpiderBasic[1981]: *** WARNING: -[NSImage compositeToPoint:operation:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:] instead.
23/02/2016 09:30:55.674 SpiderBasic[1981]: *** WARNING: -[NSImage compositeToPoint:fromRect:operation:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:] instead.
:

Re: OS X: Font issue at system level

Posted: Mon May 23, 2016 1:48 pm
by SparrowhawkMMU
Still happening - SpiderBasic, when running, is the single largest contributor to the logging system (see bottom left of the image below):

Image

Re: OS X: Font issue at system level

Posted: Sun Jan 27, 2019 1:50 pm
by Fred
I don't know if it's really SB related, i don't see it on my OS X. Can someone else confirm ?

Re: OS X: Font issue at system level

Posted: Mon Jan 28, 2019 11:08 am
by SparrowhawkMMU
Fred, I am not seeing this problem in Mojave. I searched the console for "SpiderBasic", "CoreText" and got 0 entries.

So for whatever reason, the problem has gone away :)

Re: OS X: Font issue at system level

Posted: Mon Jan 28, 2019 11:46 am
by Fred
Great !